Are your themes compatible with WordPress 5.0 and Gutenberg?

Yes. Our themes have been tested with the Gutenberg beta plugin and they are compatible with the current version of Gutenberg. We are monitoring the launch of WordPress 5.0 closely for any updates/changes to Gutenberg functionality that would require theme updates. Genesis also recently released 2.7.1 that adds support for the upcoming release of WordPress 5.0. Genesis 2.7.1 has been tested with our themes and you can safely update – but always be sure to backup your site just in case.

When WordPress 5.0 launches, we recommend waiting 2-3 weeks before updating, since it is a major release with lots of new features. Waiting to update will give developers time to work out the kinks and push inevitable bug fix updates.